DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Post general DPack questions or problem reports here.

Moderator: Sergey

DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby milanchez » December 17th, 2014, 4:37 am

Hello,

I'm unable to install the DPack v 3.8.1 in a new computer, it's a Windows 7 x64 machine with Visual Studio 2013 and Framework 4.5.1.

The setup does not recognize the new Framework and asks for the old one (unable to install the old one because "a newer version is already installed"). See the attachment.

dpack2013.png
dpack2013.png (37.14 KiB) Viewed 8702 times


Do you know any workaround for this problem?
milanchez
Starting Member
 
Posts: 1
Joined: December 16th, 2014, 5:59 am

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby Sergey » December 21st, 2014, 7:49 pm

Sorry it took me so long to reply. That's a .NET v4.5 related problem, which's been fixed a while back. I've been meaning to post an updated version so I wrapped it up over the weekend. Please download new version 3.8.3 and you should be good to go. Let me know if you're still having problems. Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby ronbeau » April 11th, 2015, 7:24 pm

Sergey,

The 3.8.3 update did not solve the problem.
I tried to install it as Administrator and it failed with the message
"Microsoft .NET Framework v4.5.50938 or higher must be installed on your computer first. Setup cannot continue"

I have both versions 4.5.1 and 4.5.2 of the .NET Frame work installed on my PC.
Version 4.5.2 is version 4.5.51209 which is later than version 4.5.50938 mentioned within the message.
Please see the attached screen Shots for details.


Any suggestions?
Attachments
Screen Shot 3.png
Third Screen Shot
Screen Shot 3.png (26.35 KiB) Viewed 8451 times
Screen Shot 2.png
Second Screen Shot
Screen Shot 2.png (10.07 KiB) Viewed 8451 times
Screen Shot 1.png
First Screen Shot
Screen Shot 1.png (13.14 KiB) Viewed 8451 times
ronbeau
Starting Member
 
Posts: 2
Joined: April 11th, 2015, 11:20 am

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby Sergey » April 11th, 2015, 8:32 pm

That's not good. Try running setup executable with /Log="<log_file_name>" parameter. Post that log file here so that I can see if I could make sense of what's going on. What's your OS version/bitness btw? Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby ronbeau » April 18th, 2015, 8:51 am

Sergey, the contents of the log file are shown below.
Let me know if there is anything else you would like me to try.
I will help anyway I can.

The installation was attempted on Windows 8.1 x64

2015-04-18 08:44:17.145 Log opened. (Time zone: UTC-04:00)
2015-04-18 08:44:17.145 Setup version: Inno Setup version 5.3.8 (a)
2015-04-18 08:44:17.145 Original Setup EXE: E:\Junk\DPack2013-3.8.3-Setup.exe
2015-04-18 08:44:17.145 Setup command line: /SL5="$C315A,397018,70656,E:\Junk\DPack2013-3.8.3-Setup.exe" /Log="log.txt"
2015-04-18 08:44:17.145 Windows version: 6.2.9200 (NT platform: Yes)
2015-04-18 08:44:17.145 64-bit Windows: Yes
2015-04-18 08:44:17.145 Processor architecture: x64
2015-04-18 08:44:17.145 User privileges: Administrative
2015-04-18 08:44:17.148 64-bit install mode: No
2015-04-18 08:44:17.148 Created temporary directory: C:\Users\Ron\AppData\Local\Temp\is-7JGUN.tmp
2015-04-18 08:44:17.154 Checking for .NET v4.5.50938 or higher
2015-04-18 08:44:17.155 Registry .NET version is 4.6.00030
2015-04-18 08:44:17.155 .NET v4.5.50938 is not detected
2015-04-18 08:44:17.155 Message box (OK):
Microsoft .NET Framework v4.5.50938 or higher must be installed on your computer first.

Setup cannot continue.
2015-04-18 08:44:20.139 User chose OK.
2015-04-18 08:44:20.139 InitializeSetup returned False; aborting.
2015-04-18 08:44:20.139 Got EAbort exception.
2015-04-18 08:44:20.139 Deinitializing Setup.
2015-04-18 08:44:20.141 Log closed.
ronbeau
Starting Member
 
Posts: 2
Joined: April 11th, 2015, 11:20 am

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby Sergey » April 18th, 2015, 11:46 am

Thanks for the log. Got it reproduced here. The assumption I made is that Visual Studio 2013 would be tied to .NET 4.5, just like all other previous versions. Instead Microsoft had released .NET 4.6 as in place update. So, I'll need to work around that, again. I'll keep you posted.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby buda56 » April 27th, 2015, 6:17 am

Hi,
Is there any progress on this, I am unable to use the latest version with windows 10 and VS 2013 (issues with the version of DotNet?).

I am using the beta okay with VS2015 but the beta expires on the 4th May.

Regards..
Peter
buda56
Junior Member
 
Posts: 6
Joined: July 14th, 2012, 11:21 am

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby Sergey » April 27th, 2015, 8:54 pm

I plan on posting another beta refresh this weekend. That'll include installation application patch I mentioned earlier. The new beta will support both VS 2013 and VS 2015 RC. Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby buda56 » May 1st, 2015, 5:26 am

Ok thanks, look forward to it..

Regards..
Peter
buda56
Junior Member
 
Posts: 6
Joined: July 14th, 2012, 11:21 am

Re: DPack 3.8.1 VS2013 incompatible with Framework 4.5.1

Postby Sergey » May 3rd, 2015, 10:21 pm

Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA


Return to DPack Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron