Goto global bookmark via shortcut breaks after restarting VS

Post general DPack questions or problem reports here.

Moderator: Sergey

Goto global bookmark via shortcut breaks after restarting VS

Postby casterle » May 7th, 2010, 12:09 pm

VS2010 Ultimate RTM
DPack 3.0.1
Win7 x64

I am able to set global bookmarks and go to them as expected (even from Design pages, which is wonderful). If I close VS2010 and then reopen it, I can see my global bookmark in the editor and in the bookmarks tool window. I can go the the bookmark by double-clicking it in the bookmark tools window. For some reason, I can't go to it via the goto bookmark key (in this case, the bookmark is set via ctrl-shift-1; the goto key is ctrl-1).

Has anyone else seen this?

Thanks!
casterle
Junior Member
 
Posts: 5
Joined: May 7th, 2010, 11:22 am

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby Sergey » May 8th, 2010, 12:51 pm

Yeah, I've had that sporadically happen to me as well but could never figure out just the right steps to reproduce it. I'd appreciate if you describe to me what kind of project/solution you have open there, i.e. language(s) used, type as library, web site, etc. Do you have VS set to load your last solution or do you load it manually after VS comes up? And lastly, probably the most important part is, what kind of files (code, Xml, Xaml, etc.) does it load when on solution load, and which one of them is the active one? Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby casterle » May 10th, 2010, 12:01 pm

This is a C# application. I have one global bookmark set in a C# file. The application is set to auto-load. The project auto-loads three C# files; one of two of them are design views, one is the C# source of one of the design views. The active form can be either a design view or a source view.

The project I'm seeing this on is one I'm using to play around with some DevExpress controls. I'd be happy to stick it on my site if you'd like to take a look at it. You'd have to install the DevExpress 9.3.4 controls; I'm using a trial version which you can download at no cost.
casterle
Junior Member
 
Posts: 5
Joined: May 7th, 2010, 11:22 am

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby Sergey » May 10th, 2010, 3:45 pm

Thanks. Part of your reply hinted at what the potential trouble area could be. It took no time to reproduce it here as well. As I suspected it's a context issue. All commands in VS are made available based on context. DPack applies it's own context on top of that. That's the area on bookmarks side that needs some improvement.

I think there is also a design oversight there, which sort of went unnoticed for a long time. While regular bookmarks are OK to be available in the context of the currently opened text file only, it doesn't translate well into global bookmarks as they should be available for the entire solution. And yet, both bookmark types are governed by the same context rules. I'll need to rework that for the next version.

To work around it in the mean time, you can switch to the text editor, right click on it to bring up the context menu or bring up Edit|Bookmarks menu. That should refresh the bookmarks context, forcing its commands to get re-enabled.

Thanks for reporting it.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby casterle » May 11th, 2010, 9:50 am

Thanks, Surgey!
casterle
Junior Member
 
Posts: 5
Joined: May 7th, 2010, 11:22 am

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby Sergey » August 25th, 2010, 11:23 pm

Should be fixed for the next version now. Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Re: Goto global bookmark via shortcut breaks after restarting VS

Postby Sergey » August 29th, 2010, 1:41 pm

The new beta 3.0.4.4 which fixes that bookmarks problem is up. Give it a shot and let me know if you're still having problems.

http://www.usysware.com/files/DPackSetup2008Beta.exe - for VS 2008, 844Kb
http://www.usysware.com/files/DPackSetup2010Beta.exe - for VS 2010, 864Kb

Thanks.
Sergey @ USysWare
User avatar
Sergey
Moderator
 
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA


Return to DPack Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron