WPrinter icon missing in system tray

Post general WPrinter questions, ask for help or discuss printing related issues here.

Moderator: Sergey

WPrinter icon missing in system tray

Postby hondoe » December 15th, 2006, 2:29 pm

I had this problem before and used System Restore to return my PC to an earlier state where WPrinter works.

Now I've gotten the same error again and do not want to use System Restore because I always lose some of the changes I've made when I use it.

I have enjoyed WPrinter for years, but it has started having a recurrent problem. After running it, the program shows up in the Windows Task Manager as a running process, but no icon appears in the system tray.

the error message that appears when the program is run is:

failed to set data for 'Icon'

can you help me please?

I tried reinstalling a new download over the old one.

I also tried uninstalling completely and reinstalling.

Neither solved the problem.


p.s. here's my log file:

12/10/2006 20:37:59.546 ***** Log started *****
12/10/2006 20:37:59.546 WPrinter Pro
12/10/2006 20:37:59.562 Windows XP (Build 2600: Service Pack 2)
12/10/2006 20:37:59.562 comctl32.dll 6.0.2900.2982
12/10/2006 20:37:59.562 hhctrl.ocx 5.2.3790.1194
12/10/2006 20:37:59.578 Check options...
12/10/2006 20:37:59.578 Check options: begin
12/10/2006 20:37:59.578 Check options: end
12/10/2006 20:37:59.578 Check for registration: begin
12/10/2006 20:37:59.578 Check for registration: end
12/10/2006 20:37:59.578 Load templates: begin
12/10/2006 20:38:33.281 Terminated a second copy
12/10/2006 20:38:38.765 Terminated a second copy
12/15/2006 10:18:11.015 ***** Log started *****
12/15/2006 10:18:11.015 WPrinter Pro
12/15/2006 10:18:11.015 Windows XP (Build 2600: Service Pack 2)
12/15/2006 10:18:11.015 comctl32.dll 6.0.2900.2982
12/15/2006 10:18:11.031 hhctrl.ocx 5.2.3790.2744
12/15/2006 10:18:11.031 Check options...
12/15/2006 10:18:11.031 Check options: begin
12/15/2006 10:18:11.031 Check options: end
12/15/2006 10:18:11.031 Check for registration: begin
12/15/2006 10:18:11.046 Check for registration: end
12/15/2006 10:18:11.046 Load templates: begin
Starting Member
Posts: 1
Joined: December 15th, 2006, 2:21 pm

Postby Sergey » December 17th, 2006, 8:45 pm


I apologize for not answering sooner as the support forums were down for 2 days.

Sorry to hear about your problem. After some head scratching and careful log dissection, I was able to reproduce your problem. It appears that you have some partially saved printer template and that's what's been causing your problem. What I call a template is what you get when you bring up Configuration dialog and modify printer's alias, icon, etc.

Template's information's stored in the registry. It appears one of your template values, Icon to be exact, is missing. Here's what you can do until I fix the problem so that it's handled a bit more gracefully. To fix that, try this:

* Bring up Registry Editor
* Navigate to HKEY_CURRENT_USER\Software\USysWare\WPrinter\Printers
* Check each printer name sub-key looking for one that doesn't have Icon value
* Add Icon string value (right click on the right hand side and select New->String Value). You don't need to set its value

Let me know if this helps or if you need some help with the above steps. Thanks.
Sergey @ USysWare
User avatar
Posts: 590
Joined: May 27th, 2005, 3:56 pm
Location: Alexandria, VA

Return to WPrinter Support

Who is online

Users browsing this forum: No registered users and 1 guest